QQ空间发图文说说接口

介绍

本接口需要自行提供QQ登录后的Qzone的 pskey, skeyQQ号

效果

用法

图片上传接口

地址

https://go.mcoo.pw/qzone/up.php

方法

POST

参数

参数名称 说明
qq QQ号(必须)
skey (必须)
pskey (必须)
pic Base64编码后的图片(必须)

返回值

你需要正则取出取出返回值 正则代码:frameElement.callback\(([\d\D]*)\)
取图片上传后的特征值(用于后面发图文说说)

    msg=re.search(r'frameElement.callback\(([\d\D]*)\)',msg1)
    pic=eval(msg.group(1))
    pic_bo = pic['data']['url'].split('&bo=')[-1]
    albumid = pic['data']['albumid']
    lloc = pic['data']['lloc']
    sloc = pic['data']['sloc']
    img_type = pic['data']['type']
    richval = ',%s,%s,%s,%s,%s,%s,,%s,%s' % (albumid, lloc, sloc, img_type,  pic['data']['height'], pic['data']['width'], pic['data']['height'], pic['data']['width'])

酷Q+易语言版本

.版本 2

.子程序 发说说, 文本型
.参数 内容, 文本型
.参数 图片地址, 文本型, 可空
.局部变量 QZoneKey, 文本型, , "0"
.局部变量 tmp, 文本型, , "0"
.局部变量 tmp1, 文本型
.局部变量 uin, 文本型
.局部变量 skey, 文本型
.局部变量 p_skey, 文本型
.局部变量 i, 整数型
.局部变量 json, 类_json
.局部变量 json1, 类_json
.局部变量 image, 文本型
.局部变量 file, 整数型
.局部变量 pic, 文本型
.局部变量 tmp2, 文本型
.局部变量 albumid, 文本型
.局部变量 pic_bo, 文本型
.局部变量 tmp3, 文本型, , "0"
.局部变量 lloc, 文本型
.局部变量 sloc, 文本型
.局部变量 img_type, 文本型
.局部变量 richval, 文本型

json.清除 ()
QZoneKey = 分割文本 (CQ.取Cookies (“qzone.qq.com”), “;”, )
.计次循环首 (取数组成员数 (QZoneKey), i)
    tmp = 分割文本 (QZoneKey [i], “=”, )
    json.置属性 (tmp [1], tmp [2])
.计次循环尾 ()
uin = 文本_替换 (json.取属性对象 (“uin”), , , , “o”, “”, #引号, “”)
skey = “@” + 文本_替换 (json.取属性对象 (“skey”), , , , #引号, “”)
p_skey = 文本_替换 (json.取属性对象 (“p_skey”), , , , #引号, “”)
.如果真 (图片地址 ≠ “”)
    file = 打开文件 (图片地址, , )
    pic = 编码_URL编码 (编码_BASE64编码 (读入字节集 (file, 取文件长度 (file))))
    关闭文件 (file)
    tmp2 = 编码_Utf8到Ansi (网页_访问 (“https://go.mcoo.pw/qzone/up.php”, 1, , , , , , , 到字节集 (“qq=” + uin + “&skey=” + skey + “&pskey=” + p_skey + “&pic=” + pic)))
    json.清除 ()
    json.解析 (文本_取出中间文本 (tmp2, “frameElement.callback(”, “);”))
    json1 = json.取属性 (“data”)
    albumid = 文本_替换 (json1.取属性对象 (“albumid”), , , , #引号, “”)
    tmp3 = 分割文本 (json1.取属性对象 (“url”), “&bo=”, )
    pic_bo = 文本_替换 (tmp3 [取数组成员数 (tmp3)], , , , #引号, “”)
    lloc = 文本_替换 (json1.取属性对象 (“lloc”), , , , #引号, “”)
    sloc = 文本_替换 (json1.取属性对象 (“sloc”), , , , #引号, “”)
    img_type = 文本_替换 (json1.取属性对象 (“type”), , , , #引号, “”)
    richval = “,” + albumid + “,” + lloc + “,” + sloc + “,” + img_type + “,” + 文本_替换 (json1.取属性对象 (“height”), , , , #引号, “”) + “,” + 文本_替换 (json1.取属性对象 (“width”), , , , #引号, “”) + “,,” + 文本_替换 (json1.取属性对象 (“height”), , , , #引号, “”) + “,” + 文本_替换 (json1.取属性对象 (“width”), , , , #引号, “”)
.如果真结束

tmp2 = 编码_Utf8到Ansi (网页_访问 (编码_URL编码EX (“https://go.mcoo.pw/qzone/send.php?” + “qq=” + uin + “&skey=” + skey + “&content=” + 内容 + “&pskey=” + p_skey + “&pic_bo=” + pic_bo + “&richval=” + richval), 0, , , , , , , ))
返回 (tmp2)
# PSkey失效返回
{
   "data" : {
      "error" : -503,
      "msg" : "对不起,您尚未登录或者登录超时。 错误码:(xxxxx-900)\n"
   },
   "ret" : -503
}

说说发送接口

地址

https://go.mcoo.pw/qzone/send.php

方法

GET

参数

参数名称 说明
qq QQ号(必须)
skey (必须)
pskey (必须)
content 说说文本(必须)
richval 图片特征值(非必须)
pic_bo 图片特征值(非必须)

返回

success

评论

  1. enjoy
    enjoy 博主
    Windows Chrome 80.0.3987.163
    6月前
    2020-4-10 13:00:08

    test

  2. enjoy
    enjoy 博主
    Windows Chrome 80.0.3987.163
    6月前
    2020-4-10 13:58:17

    test

  3. enjoy
    enjoy 博主
    Windows Chrome 80.0.3987.163
    6月前
    2020-4-10 13:58:50
    print("123")

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇